WordPress在Linux下安装插件主题时提示需要输入FTP信息

  •   
  • 1608
  • linux
  • 7
  • dodobook
  • 2014/08/22

博客系统Wordpress有很强大的插件系统和功能。也有很好的社区支援,所以wordpress的很多插件都是只需要安装启用即可。非常的方便管理和使用。

但是在Linux下会遇到 需要输入ftp账户的情况。现在很多用的都是Linux服务器,且很多都是云主机或是独立主机了。ftp账号不一定需要了。遇到这种问题,首先检查权限问题。

1.检查 wp-content 的权限, chmod -R 777 wp-content 成功之后应该就已经解决你的问题了。

2.如果第一种没成功,则请尝试

//在wp-config.php中找到如下代码:
require_once(ABSPATH . 'wp-settings.php');
//在后面添加下面的代码:
if(is_admin()) {
   add_filter('filesystem_method', create_function('$a','return "direct";' ));
   define('FS_CHMOD_DIR', 0751);
   define("FS_METHOD","direct");
   define("FS_CHMOD_DIR",0777);
  define("FS_CHMOD_FILE",0777);
}

3.如果第二种也还没成功。主要原因是wordpress主目录的权限所有者不属于apache造成的。则请尝试第三种

// 找到apache服务所使用的用户名和用户组,打开终端,输入:
   ps -aux
//找到 /usr/sbin/apach 的用户名,它就是apache的所有者,我这里是 www

//终端输入: /www/是我的web主目录也是wordpress主目录
 sudo chown www:www -R /www/

不需要每一步都执行,大多数情况下第一种方法即可。修复成功之后,再进入wordpress后台安装主题和插件不在需要FTP帐户和密码了!!

wordpres的seo已经很不错了。但是还是建议安装一些百度的插件。评论插件也不错,自己去试试吧。

人类的全部历史都告诫有智慧的人,不要笃信时运,而应坚信思想。 —— 爱献生